File Formats nscd.conf(4)
nscd.conf - name service cache daemon configuration
The nscd.conf file contains the configuration information
for nscd(1M). Each line specifies either an attribute and
a value, or an attribute, cachename, and a value. Fields
are separated either by <SPACE> or <TAB> characters. A `#'
(number sign) indicates the beginning of a comment; charac-
ters up to the end of the line are not interpreted by nscd.
cachename is represented by hosts, ipnodes, passwd, or
attribute supports the following:
Specifies name of the file to which debug info should
Use /dev/tty for standard output.
Sets the debug level desired.
value may range from 0 (the default) to 10. Use of
this option causes nscd(1M) to run in the foreground
and not become a daemon. Note that the output of the
debugging command is not likely to remain the same
from release-to-release; scripts should not rely on
enable-cache cachename value
Enables or disables the specified cache. value may
be either yes or no.
positive-time-to-live cachename value
Sets the time-to-live for positive entries (successful
queries) in the specified cache. value is in integer
seconds. Larger values increase cache hit rates and
reduce mean response times, but increase problems with
cache coherence. Note that sites that push (update)
NIS maps nightly can set the value to be the
equivalent of 12 hours or more with very good perfor-
negative-time-to-live cachename value
Sets the time-to-live for negative entries (unsuccess-
ful queries) in the specified cache. value is in
integer seconds. Can result in significant performance
improvements if there are several files owned by uids
SunOS 5.9 Last change: 9 Nov 1999 1
File Formats nscd.conf(4)
(user IDs) not in system databases; should be kept
small to reduce cache coherency problems.
suggested-size cachename value
Sets the suggested number of hash buckets in the
specified cache. This parameter should be changed only
if the number of entries in the cache exceeds the sug-
gested size by more than a factor of four or five.
Since this is the internal hash table size, value
should remain a prime number for optimum efficiency.
keep-hot-count cachename value
This attribute allows the administrator to set the
number of entries nscd(1M) is to keep current in the
specified cache. value is an integer number which
should approximate the number of entries frequently
used during the day.
check-files cachename value
Enables or disables checking the file belonging to the
specified cachename for changes. If enabled (which is
the default), changes in the corresponding file cause
the cache to be invalidated within 10 seconds. Can be
disabled if files are never modified for a slight per-
formance boost, particularly over NFS. value may be
either yes or no.
nscd(1M), group(4), hosts(4), ipnodes(4), passwd(4)
The nscd.conf interface is included in this release on an
uncommitted basis only and is subject to change or removal
in a future minor release.
SunOS 5.9 Last change: 9 Nov 1999 2