NMDM(4) BSD Kernel Interfaces Manual NMDM(4)
nmdm -- nullmodem terminal driver
The nmdm driver provides support for a device-pair termed a null modem
pair. A null modem pair is a pair of character devices. Each device
provides to a process an interface identical to that described in tty(4).
However, whereas most other devices which provide the interface described
in tty(4) have a hardware device of some sort behind them, the nmdm
device has, instead, another process manipulating it through the other
half of the pair. That is, anything written on the first device is given
to the second device as input and anything written on the second device
is presented as input on the first device.
/dev/nmdmN[AB] nullmodem device nodes. Where the A node has a match-
ing B node.
The nmdm driver first appeared in FreeBSD 4.4.
BSD July 7, 2001 BSD