NG_HUB(4) BSD Kernel Interfaces Manual NG_HUB(4)
ng_hub -- packet distribution netgraph node type
The hub node type provides a simple mechanism for distributing packets
over several links. Packets received on any of the hooks are forwarded
out the other hooks. Packets are not altered in any way.
A hub node accepts any request to connect, regardless of the hook name,
as long as the name is unique.
This node type supports only the generic control messages.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
when all hooks have been disconnected.
netgraph(4), ng_bridge(4), ng_ether(4), ng_one2many(4), ngctl(8),
The ng_hub node type appeared in FreeBSD 5.3.
Ruslan Ermilov <ruATFreeBSD.org>
BSD April 17, 2004 BSD