NG_FEC(4) BSD Kernel Interfaces Manual NG_FEC(4)
ng_fec -- netgraph Fast EtherChannel node
The fec node implements Ethernet port trunking using Cisco Fast Ether-
Channel protocol. Upon creation, node creates a network interface asso-
ciated with it. Interfaces are named ``fec0'', ``fec1'', etc. New node
takes first available unit.
The fec node accepts any hooks. However it does not use them. Under
normal operation, node should not have any hooks.
Interface membership in the FEC group is configured with the following
Attach interface to the FEC group. Target interface name is
passed as a string argument.
Remove interface from the trunk. Target interface name is passed
as a string argument.
The following control messages define forwarding method for a node:
Forwarding decisions will be made on destination link layer MAC
Forwarding decisions will be made on destination IP addresses.
This node shuts down upon receipt of a NGM_SHUTDOWN control message.
This example script creates a fec node, attaches four Ethernet interfaces
to it and sets forwarding method based on IP address:
/usr/sbin/ngctl -f- <<-SEQ
mkpeer fec dummy fec
msg fec0: add_iface "dc0"
msg fec0: add_iface "dc1"
msg fec0: add_iface "dc2"
msg fec0: add_iface "dc3"
msg fec0: set_mode_inet
The fec node type was implemented in FreeBSD 5.0.
The fec node was written by Bill Paul <wpaulATFreeBSD.org>. This manual
page was written by Gleb Smirnoff.
BSD July 22, 2004 BSD