NEP(4) BSD Kernel Interfaces Manual NEP(4)
nep -- Sun Neptune 10Gb Ethernet device
nep* at pci?
brgphy* at mii?
The nep driver provides support for various NICs based on the Sun Neptune
Ethernet controller chips, including the following:
o Sun Quad GBe UTP x8 PCI Express Card
o Sun Quad GBe UTP x8 PCIe ExpressModule
It uses an internal or external PHY or an external 10-bit interface.
The nep driver supports several media types, which are selected via the
ifconfig(8) command. The supported media types are:
Attempt to autoselect the media type (default)
media 1000baseT mediaopt full-duplex
Use 1000baseT on copper, full duplex
media 1000baseT [mediaopt half-duplex]
Use 1000baseT on copper, half duplex
media 100baseTX mediaopt full-duplex
Use 100baseTX, full duplex
media 100baseTX [mediaopt half-duplex]
Use 100baseTX, half duplex
arp(4), brgphy(4), ifmedia(4), inet(4), intro(4), netintro(4),
OpenBSD support for nep first appeared in OpenBSD 5.7.
The nep driver was written by Mark Kettenis <firstname.lastname@example.org>.
The nep driver currently only supports 1Gb Ethernet NICs. It also does
not yet use many of the advanced features the Neptune chip offers.
BSD March 24, 2017 BSD