MPII(4) Kernel Interfaces Manual MPII(4)
mpii -- LSI Logic Fusion-MPT Message Passing Interface II
mpii* at pci? dev ? function ?
The mpii driver provides support for storage controllers using the LSI
Logic Fusion-MPT Message Passing Interface II family of chipsets:
- LSISAS2004, LSISAS2008
These chipsets can be found on the following controllers:
- Dell PERC H200
- LSI SAS 9200-8e, SAS 9211-4i, SAS 9211-8i
Some models of these controllers have varying degrees of support for RAID
0 and RAID 1.
mpii supports monitoring of the logical disks in the controller through
the bioctl(8) and envstat(8) commands.
The mpii driver is able to send events to powerd(8) if a logical drive in
the controller is not online. The state-changed event will be sent to
the /etc/powerd/scripts/sensor_drive script when such condition happens.
intro(4), pci(4), scsi(4), sd(4), bioctl(8), envstat(8), powerd(8)
The mpii driver first appeared in OpenBSD 4.7.
The mpii driver was written by James Giannoules and Mike Belopuhov.
The chips supported by mpii do not use a SCSI-like identifier. Instead
they use an opaque ID and leave discovery order up to the operating
system. The code to handle this is currently not implemented and
therefore it is not a good idea to run this driver on a multi-boot
machine or with more than 1 drive.
NetBSD 6.1.5 April 19, 2012 NetBSD 6.1.5