MPE(4) BSD Kernel Interfaces Manual MPE(4)
mpe -- MPLS Provider Edge
The mpe interface is an MPLS Provider Edge pseudo-device used to enter
and leave an MPLS domain.
An mpe interface can be created at runtime using the ifconfig mpeN create
command or by setting up a hostname.if(5) configuration file for
netstart(8). The interface itself can be configured with ifconfig(8);
see its manual page for more information.
mpe interfaces support the following unique ioctls:
SIOCSETLABEL Encapsulate packets entering this interface in MPLS
using the specified label.
SIOCGETLABEL Report the label that packets entering this interface
will be tagged with.
sysctl(3), hostname.if(5), ifconfig(8), ldpd(8), netstart(8)
The mpe device first appeared in OpenBSD 4.4.
The mpe driver was written by Pierre-Yves Ritschard <firstname.lastname@example.org>.
BSD July 16, 2013 BSD