MOS(4) BSD Kernel Interfaces Manual MOS(4)
mos -- MosChip MCS7730/7830/7832 10/100 USB Ethernet device
mos* at uhub?
The mos driver provides support for USB Ethernet adapters based on the
MosChip MCS7730, MCS7830 and MCS7832 USB 2.0 chipsets, including the fol-
All adapters operate with either USB 1.x or USB 2.0 controllers, though
performance with 1.x controllers is limited since the USB 1.x standard
specifies a maximum transfer speed of 12Mbps. Users with USB 1.x con-
trollers should therefore not expect to actually achieve 100Mbps speeds
with these devices.
A 64-bit multicast hash table is supported, single perfect filter entry
for the station address, all-multicast mode, and promiscuous mode. Pack-
ets are received and transmitted over separate USB bulk transfer end-
The mos driver supports the following media types:
autoselect Enable autoselection of the media type and options (this is
the default). The user can manually override the autose-
lected mode by adding media options to the appropriate
10baseT Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
The mos driver supports the following media options:
full-duplex Force full-duplex operation.
half-duplex Force half-duplex operation.
For more information on configuring this device, see ifconfig(8).
mos0: watchdog timeout A packet was queued for transmission and a trans-
mit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
mos0: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
arp(4), ifmedia(4), intro(4), netintro(4), usb(4), hostname.if(5),
MosChip India, http://www.moschip.com.
The mos device driver first appeared in OpenBSD 4.5.
The mos driver was written by Johann Christian Rode <firstname.lastname@example.org>.
BSD April 25, 2017 BSD