MII(4) BSD Kernel Interfaces Manual MII(4)
mii -- IEEE 802.3 Media Independent Interface
acphy* at mii?
amphy* at mii?
atphy* at mii?
bmtphy* at mii?
brgphy* at mii?
ciphy* at mii?
dcphy* at mii?
eephy* at mii?
etphy* at mii?
exphy* at mii?
gentbi* at mii?
icsphy* at mii?
ipgphy* at mii?
inphy* at mii?
iophy* at mii?
jmphy* at mii?
luphy* at mii?
lxtphy* at mii?
mtdphy* at mii?
nsgphy* at mii?
nsphy* at mii?
nsphyter* at mii?
qsphy* at mii?
rdcphy* at mii?
rgephy* at mii?
rlphy* at mii?
sqphy* at mii?
tlphy* at mii?
tqphy* at mii?
txphy* at mii?
ukphy* at mii?
urlphy* at mii?
xmphy* at mii?
Media Independent Interface is an IEEE standard serial bus for connecting
MACs (network controllers) to PHYs (physical media interfaces). The mii
layer allows network device drivers to share support code for various PHY
models, and allows unused support for PHYs which are not present in a
system to be removed from the kernel.
Network device drivers which use the mii layer carry the ``mii'' autocon-
figuration attribute. This allows kernel configuration files to simply
specify PHYs as described above in SYNOPSIS.
The following is an example of the messages displayed when a network
interface with an attached PHY is detected by the kernel:
hme0 at sbus0 slot 1 offset 0x8c00000 pri 7: address 08:00:20:22:86:b8 rev 34
nsphy0 at hme0 phy 1: DP83840 10/100 PHY, rev. 1
ifconfig(8) can be used to display the media types supported by the PHY.
These media types are valid media keywords for use with the ifconfig(8)
acphy(4), amphy(4), atphy(4), bmtphy(4), brgphy(4), ciphy(4), dcphy(4),
eephy(4), etphy(4), exphy(4), gentbi(4), icsphy(4), ifmedia(4), inphy(4),
intro(4), iophy(4), ipgphy(4), jmphy(4), luphy(4), lxtphy(4), mtdphy(4),
netintro(4), nsgphy(4), nsphy(4), nsphyter(4), qsphy(4), rdcphy(4),
rgephy(4), rlphy(4), sqphy(4), tlphy(4), tqphy(4), txphy(4), ukphy(4),
urlphy(4), xmphy(4), ifconfig(8)
BSD January 15, 2011 BSD