MBG(4) BSD Kernel Interfaces Manual MBG(4)
mbg -- Meinberg Funkuhren timedelta sensor
mbg* at pci?
The mbg driver provides support for Meinberg Funkuhren radio clocks (time
signal station and GPS receivers). mbg implements a timedelta sensor and
the delta (in nanoseconds) between the received time information and the
local time can be accessed through the sysctl(8) interface.
The card type is indicated in the sensor description. Currently, the
following cards are supported by mbg:
GPS170PCI 3.3V/5V 6-channel GPS receiver card
PCI32 5V DCF77 time signal station receiver card
PCI509 5V DCF77 time signal station receiver card
PCI511 3.3V/5V DCF77 time signal station receiver card
PEX511 PCI Express DCF77 time signal station receiver card
The quality of the timedelta is reported as the sensor status:
UNKNOWN No valid time information has been received yet.
OK The time information is valid and the timedelta is safe
to use for applications like ntpd(8).
WARN The time information is still valid, but no new time
information has been decoded for twelve hours (four
days in the case of a GPS170PCI card) due to a recep-
tion or parity error. The timedelta should be used
CRITICAL No valid time information has been received for more
than twelve hours (or four days in the case of a
GPS170PCI card) since the sensor state degraded from OK
to WARN. This is an indication that hardware should be
checked to see if it is still functional.
A second sensor provides the relative signal quality as a percentage.
The status of this sensor is used to report the status of the device
OK The clock is synchronized.
WARN The device's clock is free running on the local oscil-
lator. For DCF77 receiver cards this is not an error
and can happen due to the nature of the signal trans-
mission using longwave radio.
CRITICAL Hardware failure, e.g. communication with the device
intro(4), pci(4), ntpd(8), sysctl(8)
The mbg driver first appeared in OpenBSD 4.1.
The mbg driver was written by Marc Balmer <firstname.lastname@example.org>.
BSD March 28, 2017 BSD