LO(4) BSD Kernel Interfaces Manual LO(4)
lo -- software loopback network interface
The loop interface is a software loopback mechanism which may be used for
performance analysis, software testing, and/or local communication.
A loop interface can be created at runtime using the ifconfig loN create
command or by setting up a hostname.if(5) configuration file for
netstart(8). The lo0 interface will always exist and cannot be destroyed
As with other network interfaces, the loopback interface must have net-
work addresses assigned for each address family with which it is to be
used. These addresses may be set or changed with the SIOCSIFADDR
ioctl(2). The loopback interface should be the last interface config-
ured, as protocols may use the order of configuration as an indication of
priority. The loopback should never be configured first unless no hard-
ware interfaces exist.
lo0: can't handle afX. The interface was handed a message with addresses
formatted in an unsuitable address family; the packet was dropped.
inet(4), inet6(4), netintro(4), hostname.if(5), ifconfig(8), netstart(8)
The lo device appeared in 4.2BSD.
Previous versions of the system enabled the loopback interface automati-
cally, using a non-standard Internet address (127.1). Use of that
address is now discouraged; a reserved host address for the local network
should be used instead.
BSD March 24, 2017 BSD