LMC(4) BSD Kernel Interfaces Manual LMC(4)
lmc -- Lan Media Corporation SSI/T1/DS1/HSSI/DS3 card device
lmc* at pci?
The lmc driver provides support for the Lan Media Corporation SSI,
T1/DS1, HSSI, and DS3 PCI WAN adapters based on the DEC 21140 Ethernet
chip. The adapters use a DEC 21140 Ethernet chip for the PCI bus inter-
face. Leaving the bus interface chip, the data path goes through a field
programmable gate array, where HDLC processing is accomplished. Leaving
the FPGA, there are FIFO buffers and the DS1, DS3, and V.35 drive cir-
The intent is to provide a synchronous serial link with HDLC framing at
speeds of up to 10Mbps (for the SSI card), 52Mbps (for the HSSI card),
BNC connectors for 45Mbps operation without a CSU/DSU (DS3 card), and an
RJ45 jack for T1/E1 operation without a CSU/DSU (T1/DS1 card).
The card will automatically use HDLC framing and defaults to external
clock source. For the DS1 and DS3 cards with built-in CSU/DSU function-
ality, the clock source is always external (from CSU/DSU). The ability
to set cable length is not currently implemented.
Using the sppp(4) driver, you can also use the ppp protocol. In either
case, the lmc interface should be configured as a point-to-point link.
lmc0: couldn't map interrupt A fatal initialization error has occurred.
lmc0: couldn't establish interrupt A fatal initialization error has
lmc0: enabling keepalive Cisco HDLC keepalive packets will be transmit-
lmc0: disabling keepalive Cisco HDLC keepalive packets will not be
lmc0: clock internal The card is using internal clocking for the line.
lmc0: clock external The card is using external clocking for the line.
lmc0: asserting DTR and RTS The card is sending DTR and RTS signals on
lmc0: deasserting DTR and RTS The card is not sending DTR and RTS sig-
nals on the line.
lmc0: Abnormal interrupt The card received an incomplete request. This
may be a sign of a hardware fault.
lmc0: tx_intr: failed to dequeue mbuf?!? Only available if compiled with
lmc0: txput: tx not running Problem from tulip. Only available if com-
piled with LMC_DEBUG.
netintro(4), sppp(4), ifconfig(8), lmccontrol(8)
The lmc device driver was written by Michael Graff, and was derived in
part from Matt Thomas' de(4) driver. The OpenBSD port and manual page
are from Chris Cappuccio. Later enhancements to support the LMC1200 card
are based on LMC's Linux driver.
BSD March 24, 2017 BSD