LGE(4) BSD Kernel Interfaces Manual LGE(4)
lge -- Level 1 LXT1001 NetCellerator PCI Gigabit Ethernet device
lge* at pci?
xmphy* at mii?
The lge driver provides support for various NICs based on the Level 1
LXT1001 NetCellerator Gigabit Ethernet controller chip, including the
o Allied Telesis CentreCOM LA1000-PCI-SX
o D-Link DGE-500SX
o SMC TigerCard 1000 (SMC9462SX)
These NICs are capable of 1000Mbps speeds over fiber optic cable. The
LXT1001 also supports a GMII port for use with 10/100/1000 copper PHYs,
however there aren't currently any NICs on the market that use this fea-
The LXT1001 supports IPv4 receive IP/TCP/UDP checksum offload as well as
a 64-bit multicast hash filter. It also supports jumbo frames.
The lge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the appropriate hostname.if(5) file.
1000baseSX Set 1000baseSX operation over fiber optic cable. Both
full-duplex and half-duplex modes are supported.
The lge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
lge0: can't map i/o space A fatal initialization error has occurred.
lge0: couldn't map interrupt A fatal initialization error has occurred.
lge0: no memory for jumbo buffer queue! The driver failed to allocate
memory for jumbo frames during initialization.
lge0: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), xmphy(4),
Level 1 LXT1001 Programming Manual,
The lge device driver first appeared in OpenBSD 3.0.
The lge driver was written by Bill Paul <firstname.lastname@example.org>.
BSD September 14, 2014 BSD