KAME(4) BSD Kernel Interfaces Manual KAME(4)
KAME -- introduction and roadmap to KAME IPv6 software package
KAME software package is a result of joint work of several IPv6
researchers in Japan, to provide reference implementation of IPv6 to
Berkeley Software Distribution (BSD) derived system such as BSD/OS,
FreeBSD, NetBSD and OpenBSD (in alphabetical order).
KAME kit consists of IPv6/IPsec-ready kernel, application, daemons,
header files and libraries.
Following are some of highlights of this implementation.
Note: features not yet integrated into FreeBSD are marked with the (-)
IPv6 and IPsec protocol stacks are implemented and available. See below
for conformance to standards and/or internet drafts.
Plug and Play and protocol stack/interface configuration
ndp(8), rrenumd(8), rtadvd(8), rtsol(8), rtsold(8).
Multicast (includes routing and utilities)
mchat(1) (-), ifmcstat(8), pim6dd(8) (ports/net/pim6dd), pim6sd(8)
Two IPv4 to IPv6 transition tools are available. TCP relay translator,
FAITH (faithd(8)) and SIIT IPv6-to-v4 header translator implementation
(ptrconfig(8)). ptrconfig(8) is not yet integrated into FreeBSD.
IPsec and tunnelling
ipsec(4), racoon(8) (ports/security/racoon), setkey(8).
Dozen of existing tools are modified for IPsec support, like ping(8).
v6test(1) (-), ping6(8), traceroute6(8).
Dozen of existing utilities are modified for IPv6/IPsec support, like
ftp(1) and/or telnet(1).
inetd(8) modified for IPv4/v6 support, or IPv6-only inet6d(8) (-) is sup-
Dozen of existing daemons are modified for IPv6/IPsec support, like
ftpd(8) and/or telnetd(8).
Although some of documentations have not modified yet, program itself may
be heavily modified. Following lists are not complete, but give you some
idea what kind of new software modules are available, or, modifications
are made. Please refer to each manual page for detail.
Installation and basic usage documentations
Please read the following files in the directories /usr/share/doc/IPv6
and /usr/share/examples/IPv6 to get a basic idea of (and installation
methods for KAME. You also can check out the IPv6 and IPsec chapters in
the FreeBSD handbook. Also check latest status of project at web page:
http://www.kame.net/. (Hope you can see a ``Dancing Turtle'' :-))
APIs introduced or modified
if_indextoname(3), getipnodebyname(3), gethostbyname(3), rresvport_af(3),
hosts_ctl(3), ipsec_get_policylen(3), getnameinfo(3), freeaddrinfo(3),
getaddrinfo(3), pcap(3), getipnodebyaddr(3), resolver(3),
ipsec_strerror(3), gai_strerror(3), hosts_access(3), request_set(3),
request_init(3), freehostent(3), if_nameindex(3), if_freenameindex(3),
if_nametoindex(3), ipsec_dump_policy(3), ipsec_set_policy(3)
Added/modified/renamed features and tools
Please consult the manpages referred above.
To understand KAME protocol stack conformance, please refer to
Bug reporting form, user mailing list, frequently asked questions list,
latest packages, related software, and more information can be found at
TAHI project who is providing verification technology for IPv6, is heav-
ily related with KAME project. You can get current verification status
of KAME software at following TAHI project web page: http://www.tahi.org/
The KAME project started in April 1999. KAME kit was mostly integrated
into FreeBSD by Youshinobu Inoue <shinATFreeBSD.org> in January 2000.
BSD April 13, 1999 BSD