IWM(4) BSD Kernel Interfaces Manual IWM(4)
iwm -- Intel 7200 IEEE 802.11a/ac/b/g/n wireless network devices
iwm* at pci?
The iwm driver provides support for Intel Wireless 7260, 7265, and 3160
PCIe Mini Card network adapters.
These are the modes the iwm driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
The iwm driver can be configured to use Wired Equivalent Privacy (WEP) or
Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless communica-
tion, due to serious weaknesses in it.
The iwm driver can be configured at runtime with ifconfig(8) or on boot
The driver needs one of the following firmware files, which are loaded
when an interface is brought up:
These firmware files are not free because Intel refuses to grant distri-
bution rights without contractual obligations. As a result, even though
OpenBSD includes the driver, the firmware files cannot be included and
users have to download these files on their own.
A prepackaged version of the firmware can be installed using
The following example scans for available networks:
# ifconfig iwm0 scan
The following hostname.if(5) example configures iwm0 to join network
``mynwid'', using WPA key ``mywpakey'', obtaining an IP address using
iwm0: device timeout A frame dispatched to the hardware for transmission
did not complete in time. The driver will reset the hardware. This
should not happen.
iwm0: fatal firmware error For some reason, the firmware crashed. The
driver will reset the hardware. This should not happen.
iwm0: radio is disabled by hardware switch The radio transmitter is off
and thus no packet can go out. The driver will reset the hardware. Make
sure the laptop radio switch is on.
iwm0: could not read firmware ... (error N) For some reason, the driver
was unable to read the firmware image from the filesystem. The file
might be missing or corrupted.
iwm0: firmware too short: N bytes The firmware image is corrupted and
can't be loaded into the adapter.
iwm0: could not load firmware An attempt to load the firmware into the
adapter failed. The driver will reset the hardware.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5),
The iwm driver does not support any of the 802.11n and 802.11ac capabili-
ties offered by the adapters. Additional work is required in
ieee80211(9) before those features can be supported.
The firmware stops passing traffic if the MAC address is changed with
# ifconfig iwm0 lladdr ...
Occasionally, firmware errors occur before association to a wireless net-
work has completed. Several attempts may be required before link is suc-
BSD March 30, 2017 BSD