IWI(4) BSD Kernel Interfaces Manual IWI(4)
iwi -- Intel PRO/Wireless 2200BG/2225BG/2915ABG IEEE 802.11a/b/g wireless
iwi* at pci?
The iwi driver provides support for Intel PRO/Wireless 2200BG/2915ABG
Mini PCI and 2225BG PCI network adapters.
These are the modes the iwi driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
IBSS mode Also known as IEEE ad-hoc mode or peer-to-peer mode. This
is the standardized method of operating without an access
point. Stations associate with a service set. However,
actual connections between stations are peer-to-peer.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The iwi driver can be configured to use Wired Equivalent Privacy (WEP) or
Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless communica-
tion, due to serious weaknesses in it. The iwi driver relies on the
software 802.11 stack for both encryption and decryption of data frames.
The iwi driver can be configured at runtime with ifconfig(8) or on boot
The driver needs at least version 3.1 of the following firmware files,
which are loaded when an interface is brought up:
These firmware files are not free because Intel refuses to grant distri-
bution rights without contractual obligations. As a result, even though
OpenBSD includes the driver, the firmware files cannot be included and
users have to download these files on their own. The official person to
state your views to about this issue is email@example.com.
A prepackaged version of the firmware can be installed using
The following example scans for available networks:
# ifconfig iwi0 scan
The following hostname.if(5) example configures iwi0 to join network
``mynwid'', using WPA key ``mywpakey'', obtaining an IP address using
iwi0: device timeout The driver will reset the hardware. This should
iwi0: error N, could not read firmware ... For some reason, the driver
was unable to read the firmware image from the filesystem. The file
might be missing or corrupted.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5),
The iwi driver was written by Damien Bergamini
BSD March 28, 2017 BSD