ITHERM(4) BSD Kernel Interfaces Manual ITHERM(4)
itherm -- Intel 3400 temperature sensor
itherm* at pci?
The itherm driver provides support for several sensors found in Intel
3400 and 5 series chipsets.
The sensors currently exposed via the sysctl(8) interface are:
Sensor Units Typical Use
Thermometer degC Temperature
Core 1 degC Temperature
Core 2 degC Temperature
CPU power cons. Watts Power usage
CPU/GPU Max degC Temperature
DIMM 1 degC Temperature
DIMM 2 degC Temperature
DIMM 3 degC Temperature
DIMM 4 degC Temperature
GPU abs. degC Temperature
PCH abs. degC Temperature
pci(4), sensorsd(8), sysctl(8)
The itherm driver first appeared in OpenBSD 4.8.
The itherm driver was written by Mike Larkin <firstname.lastname@example.org>.
Not all sensors are wired on every machine, so the list of sensors shown
in sysctl(8) may not show all the sensors listed above. Furthermore, the
itherm driver will flag sensors as invalid if they report bogus data.
BSD April 29, 2017 BSD