ISDN(4) Kernel Interfaces Manual ISDN(4)
isdn -- ISDN kernel to userland master device
The isdn device driver is used by the isdnd(8) daemon to exchange
messages with the ISDN kernel part for the purpose of call establishment,
control and disconnection and to access various control and status
The messages and message parameters are documented in the include file
The available ioctl's are:
Request a unique Call Description IDentifier (cdid) which
identifies uniquely a single interaction of the local D
channel with the exchange.
Actively request a call setup to a remote ISDN subscriber.
Respond to an incoming call, either accept, reject or
Actively terminate a connection.
Request information about an installed ISDN controller
Give information about call setup to driver who requested
Update the kernels timeout value(s) in case of dynamically
calculated shorthold mode timing changes.
Inform the kernel userland drivers about interface soft
up/down status changes.
Download firmware to active card(s).
Return diagnostic information from active cards.
Status and event messages available from the kernel are:
An incoming call from a remote ISDN user is indicated.
After an incoming call has been accepted locally or an
outgoing call has been accepted by a remote, the exchange
signaled an active connection and the corresponding B-
channel is switched through.
A call was terminated.
A userland interface driver requests the daemon to dial out
(typically a network interface when a packet arrives in its
A call was terminated by the isdn4bsd kernel driver because
a B-channel idle timeout occurred.
Accounting information from a network driver.
Charging information from the kernel.
The isdn device driver and this man page were written by Hellmuth
NetBSD 6.1.5 February 3, 1998 NetBSD 6.1.5