IPW(4) BSD Kernel Interfaces Manual IPW(4)
ipw -- Intel PRO/Wireless 2100 IEEE 802.11b wireless network device
ipw* at pci?
The ipw driver provides support for the Intel PRO/Wireless 2100 Mini PCI
These are the modes the ipw driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
IBSS mode Also known as IEEE ad-hoc mode or peer-to-peer mode. This
is the standardized method of operating without an access
point. Stations associate with a service set. However,
actual connections between stations are peer-to-peer.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The ipw driver can be configured to use Wired Equivalent Privacy (WEP) or
Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless communica-
tion, due to serious weaknesses in it. The ipw driver relies on the
software 802.11 stack for both encryption and decryption of data frames.
The ipw driver can be configured at runtime with ifconfig(8) or on boot
The driver needs at least version 1.3 of the following firmware files,
which are loaded when an interface is brought up:
These firmware files are not free because Intel refuses to grant distri-
bution rights without contractual obligations. As a result, even though
OpenBSD includes the driver, the firmware files cannot be included and
users have to find these files on their own. The official person to
state your views to about this issue is firstname.lastname@example.org.
A prepackaged version of the firmware can be installed using
The following example scans for available networks:
# ifconfig ipw0 scan
The following hostname.if(5) example configures ipw0 to join network
``mynwid'', using WPA key ``mywpakey'', obtaining an IP address using
ipw0: device timeout The driver will reset the hardware. This should
ipw0: error N, could not read firmware ... For some reason, the driver
was unable to read the firmware image from the filesystem. The file
might be missing or corrupted.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5),
The ipw driver was written by Damien Bergamini
BSD February 17, 2015 BSD