IPS(4) BSD Kernel Interfaces Manual IPS(4)
ips -- IBM SATA/SCSI ServeRAID controller
ips* at pci?
The ips driver provides support for IBM ServeRAID controllers, including:
o ServeRAID 3H/3HB/3L
o ServeRAID 4H/4L/4Lx/4M/4Mx
o ServeRAID 5i/5i II
o ServeRAID 6i/6M
o ServeRAID 7k/7M/7t
Although the controllers are actual RAID controllers, the driver makes
them look just like SCSI controllers. All RAID configuration is done
through the bootable IBM ServeRAID Support CD; a CD image is freely
available at the IBM website.
The management interface is provided through the bio(4) device or one of
the daughter sd(4) devices as implemented in the bioctl(8) utility. Log-
ical disk status is exposed under the hw.sensors sysctl(8) and can be
monitored using sensorsd(8).
bio(4), intro(4), pci(4), scsi(4), sd(4), bioctl(8), sensorsd(8),
The ips driver first appeared in OpenBSD 4.1.
The ips driver was written by Alexander Yurchenko <firstname.lastname@example.org>.
Due to bioctl(8) limitations the ips driver associates all unused and hot
spare drives with the first volume but the drives can be used for
rebuilding any degraded volume.
BSD March 24, 2017 BSD