inetd.conf - configuration file for inetd
On invocation, the inetd daemon reads its configuration information
from the /etc/inetd.conf configuration file, and possibly at some
later time in response to a SIGHUP signal (see inetd(1M)).
Each line in the file is treated either as a comment or as
configuration information for a given service Comments are denoted by
a # at the beginning of a line. Noncomment lines contain seven or
nine required fields, depending on the service name specified in the
first field. Fields are separated by tabs and/or spaces. A line can
be continued if it terminates with a \. Each configuration line in
the file contains the following fields in the order indicated:
+ service name
+ socket type
+ server program
+ program number (NFS RPC services only)
+ version number (NFS RPC services only)
+ server program arguments
Fields are constructed as follows:
service name rpc if the server is RPC-based (NFS);
otherwise, the name of a valid service in
file /etc/services. For example, shell for
the remsh service (see remsh(1)), login for
the rlogin service (see rlogin(1)), and
telnet for the telnet service (see
socket type stream, dgram, or xti, depending on whether
the server socket is a stream or a datagram
socket, or intended for a program built using
the XTI API.
protocol Must be a valid protocol as given in
/etc/protocols; for example, tcp or udp. If
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
XTI is specified in the socket type field, a
full pathname to a device may be specified
here, such as /dev/tcp; otherwise, the
protocol specified here will be appended to
/dev/. For example, if tcp is specified for
an XTI application, the path /dev/tcp will be
wait|swait|nowait Specifies whether inetd should act as a
single- or multi-threaded server.
wait Instructs inetd to start one server
to handle an incoming request, and
cease listening for new requests
for the same service until the
server that started has exited.
swait Same as wait, but instructs inetd
to expect the server to accept the
nowait Instructs inetd to start one server
for each incoming request.
Most UDP-based services use wait for this
field, while TCP-based services use nowait.
user User ID to be used when the server is
server program Absolute path name of the program executed by
inetd when it finds a request on the server's
server program arguments
Arguments to the server program. The same as
in normal use, starting with argv, which
is the name of the program.
If service name is rpc (NFS RPC services), two extra fields are
required. They must appear between the server program field and the
server program arguments field:
program number Defines a particular service grouping and is
version number Version supported by the RPC service. This
number can be a single value, or a range, if
the program handles multiple versions; for
example, 1 or 1-3. Ranges are separated by a
hyphen (-). Version numbers allow RPC
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000
protocols to be extended and modified, and
make it possible for old and new protocols to
share the same server process.
Built-in inetd Services
The inetd daemon provides several "trivial" services internally by use
of built-in routines (see inetd(1M) for a list of these services). To
configure an internal service, specify internal as the server program
name, and omit the server program arguments field.
Configure the shell service to use TCP protocol, and run the server
remshd as user root.
shell stream tcp nowait root /usr/lbin/remshd remshd
Configure the FTP server to timeout an inactive session after 75
ftp stream tcp nowait root /usr/lbin/ftpd ftpd -t75
Configure an RPC-based service. Note that the service name field
contains rpc and two more fields are used: the program number (100008)
and version number (1).
rpc dgram udp wait root /usr/lib/netsvc/rwall/rpc.rwalld 100008 1
Configure inetd to use the built-in daytime TCP service.
daytime stream tcp nowait root internal
inetd.conf was developed by the University of California, Berkeley.
NFS was developed by Sun Microsystems, Inc.
inetd(1M), exec(2), fork(2), inetd.sec(4), protocols(4), services(4).
Hewlett-Packard Company - 3 - HP-UX Release 11i: November 2000