VLAN(4) BSD Kernel Interfaces Manual VLAN(4)
vlan -- IEEE 802.1Q VLAN network interface
The vlan driver demultiplexes frames tagged according to the IEEE 802.1Q
standard into logical vlan network interfaces, which allows rout-
ing/bridging between multiple VLANs through a single switch trunk port.
Each vlan interface is created at runtime using interface cloning. This
is most easily done with the ifconfig(8) create command or using the
cloned_interfaces variable in rc.conf(5).
To function, a vlan interface must be assigned a parent interface and
numeric VLAN tag using ifconfig(8). A single parent can be assigned to
multiple vlan interfaces provided they have different tags. The parent
interface is likely to be an Ethernet card connected to a properly con-
figured switch port. The VLAN tag should match one of those set up in
the switched network.
The vlan driver supports efficient operation over parent interfaces that
can provide help in processing VLANs. Such interfaces are automatically
recognized by their capabilities. Depending on the level of sophistica-
tion found in a physical interface, it may do full VLAN processing or
just be able to receive and transmit frames exceeding the maximum Ether-
net frame size by the length of a 802.1Q header. The capabilities may be
user-controlled by the respective parameters to ifconfig(8), vlanhwtag
and vlanmtu. However, a physical interface is not obliged to react to
them: It may have either capability enabled permanently without a way to
turn it off. The whole issue is very specific to a particular device and
By now, the list of physical interfaces able of full VLAN processing in
the hardware is limited to the following devices: bge(4), em(4), gx(4),
ixgb(4), nge(4), re(4), ti(4), txp(4), and vge(4).
The rest of the Ethernet interfaces can run VLANs using software emula-
tion in the vlan driver. However, most of them lack the capability of
transmitting and receiving oversized frames. Assigning such an interface
as the parent to vlan will result in a reduced MTU on the corresponding
vlan interfaces. In the modern Internet, this is likely to cause tcp(4)
connectivity problems due to massive, inadequate icmp(4) filtering that
breaks the Path MTU Discovery mechanism.
The interfaces that support oversized frames are as follows:
bfe(4) supports long frames for vlan natively.
dc(4) supports long frames for vlan natively.
de(4) requires defining BIG_PACKET in the
/usr/src/sys/pci/if_de.c source file and rebuilding the
kernel or module. The hack works only for the 21041,
21140, and 21140A chips.
fxp(4) supports long frames for vlan natively.
hme(4) supports long frames for vlan natively.
rl(4) supports long frames for vlan natively.
sis(4) supports long frames for vlan natively.
ste(4) supports long frames for vlan natively.
tl(4) has support for long frames.
tx(4) supports long frames for vlan natively.
xl(4) supports long frames only if the card is built on a newer
chip (Cyclone and above).
The vlan driver automatically recognizes devices that natively support
oversized frames for vlan use and calculates the appropriate frame MTU
based on the capabilities of the parent interface. The other interfaces
listed above can handle oversized frames, but they do not advertise this
ability of theirs. The MTU setting on vlan can be corrected manually if
used in conjunction with such parent interface.
kqueue(2), miibus(4), ifconfig(8)
No 802.1Q features except VLAN tagging are implemented.
EVFILT_NETDEV events on a vlan interface will be sent through kqueue(2)
only if the parent interface uses miibus(4) for link state notification.
BSD January 30, 2005 BSD