GEM(4) BSD Kernel Interfaces Manual GEM(4)
gem -- ERI/GEM/GMAC Ethernet device driver
The gem driver provides support for the GMac Ethernet hardware found
mostly in the last Apple PowerBooks G3s and most G4-based Apple hardware,
as well as many Sun UltraSPARCs.
Cards supported by gem driver include:
o Sun GEM gigabit Ethernet
o Sun ERI 10/100 Mbps Ethernet
o Apple GMAC
On sparc64 the gem driver respects the local-mac-address? system configu-
ration variable which can be set in the Open Firmware boot monitor using
the setenv command or by eeprom(8). If set to ``false'' (the default),
the gem driver will use the system's default MAC address for all of its
devices. If set to ``true'', the unique MAC address of each interface is
used if present rather than the system's default MAC address.
Supported interfaces having their own MAC address include the on-board
Sun ERI 10/100 Mbps and GEM gigabit Ethernet Interfaces on boards
equipped with more than one Ethernet interface and the Sun GEM gigabit
Ethernet add-on cards.
hme(4), miibus(4), netintro(4), eeprom(8), ifconfig(8)
The gem device driver appeared in NetBSD 1.6. The first FreeBSD version
to include it was FreeBSD 5.0.
The gem driver was written by Eduardo Horvath <eehATNetBSD.org>. The man
page was written by Thomas Klausner <wizATNetBSD.org>.
BSD August 15, 2004 BSD