AXE(4) BSD Kernel Interfaces Manual AXE(4)
axe -- ASIX Electronics AX88172 USB Ethernet driver
The axe driver provides support for USB Ethernet adapters based on the
ASIX Electronics AX88172 USB 2.0 chipset.
The AX88172 is a USB 2.0 device which contains a 10/100 Ethernet MAC with
MII interface and is designed to work with both Ethernet and HomePNA
transceivers. The AX88172 will operate with both USB 1.x and USB 2.0
controllers, however performance with 1.x controllers will be limited
since the USB 1.x standard specifies a maximum transfer speed of 12Mbps.
Users with USB 1.x controllers should therefore not expect to actually
achieve 100Mbps speeds with these devices.
The AX88172 supports a 64-bit multicast hash table, single perfect filter
entry for the station address, all-multicast mode and promiscuous mode.
Packets are received and transmitted over separate USB bulk transfer end-
The axe driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the /etc/rc.conf file.
10baseT/UTP Set 10Mbps operation. The mediaopt option can also be used
to enable full-duplex operation. Not specifying full-duplex
implies half-duplex mode.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to enable full-duplex operation. Not spec-
ifying full-duplex implies half-duplex mode.
The axe driver supports the following media options:
full-duplex Force full duplex operation. The interface will operate in
half duplex mode if this media option is not specified.
For more information on configuring this device, see ifconfig(8).
The axe driver supports ASIX Electronics AX88172 based USB Ethernet
o Buffalo (Melco Inc.) LUA-U2-KTX
o D-Link DUBE100
o LinkSys USB200M
o Netgear FA120
o System TALKS Inc. SGC-X2UL
axe%d: watchdog timeout A packet was queued for transmission and a
transmit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
axe%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
arp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
ASIX AX88172 data sheet, http://www.asix.com.tw.
The axe device driver first appeared in FreeBSD 5.0.
The axe driver was written by Bill Paul <wpaulATwindriver.com>.
BSD August 25, 2004 BSD