ICMP(4) BSD Programmer's Manual ICMP(4)
icmp - Internet Control Message Protocol
socket(AF_INET, SOCK_RAW, proto);
ICMP is the error and control message protocol used by IP and the Inter-
net protocol family. It may be accessed through a ``raw socket'' for
network monitoring and diagnostic functions. The proto parameter to the
socket call to create an ICMP socket is obtained from getprotobyname(3).
ICMP sockets are connectionless, and are normally used with the sendto
and recvfrom calls, though the connect(2) call may also be used to fix
the destination for future packets (in which case the read(2) or recv(2)
and write(2) or send(2) system calls may be used).
Outgoing packets automatically have an IP header prepended to them (based
on the destination address). Incoming packets are received with the IP
header and options intact.
A socket operation may fail with one of the following errors returned:
[EISCONN] when trying to establish a connection on a socket which
already has one, or when trying to send a datagram with
the destination address specified and the socket is al-
[ENOTCONN] when trying to send a datagram, but no destination ad-
dress is specified, and the socket hasn't been connect-
[ENOBUFS] when the system runs out of memory for an internal data
[EADDRNOTAVAIL] when an attempt is made to create a socket with a net-
work address for which no network interface exists.
send(2), recv(2), intro(4), inet(4), ip(4)
The icmp protocol appeared in 4.3BSD.
4.3 Berkeley Distribution June 5, 1993 1