ICHIIC(4) BSD Kernel Interfaces Manual ICHIIC(4)
ichiic -- Intel ICH SMBus controller
ichiic* at pci?
iic* at ichiic?
The ichiic driver provides support for the Intel ICH SMBus host interface
to be used with the iic(4) framework.
o Intel ICH, ICH2, ICH3, ICH4, ICH4-M, ICH5, ICH5R, ICH6, ICH6-M,
ICH6R, ICH7, ICH8, ICH9, ICH10, C-ICH, PCH, 6300ESB and
iic(4), intro(4), pci(4)
The ichiic driver first appeared in OpenBSD 3.9.
The ichiic driver was written by Alexander Yurchenko
The driver doesn't support I2C commands with a data buffer size of more
than 2 bytes.
BSD March 28, 2017 BSD