hosts - host name data base
The file /etc/hosts associates Internet (IP) addresses with official
host names and aliases. This allows a user to refer to a host by a
symbolic name instead of an Internet address.
Note: This file must contain all addresses for local interfaces that
ifconfig needs at boot time (see ifconfig(1M)). When using the name
server (see named(1M)), or Network Information Service (see
ypserv(1M)), this file often serves as a backup when the server is not
running. In such circumstances, it is a common practice for
/etc/hosts to contain a few addresses of machines on the local
/etc/hosts should contain a single line for each host with the
<internet address> <official host name> <aliases>
Aliases are other names by which a host is known. They can substitute
for the official host name in most commands. For example:
18.104.22.168 hpdxsg testhost
In this example, users can use remote login on hpdxsg by using the
If your system is in a domain naming environment, an official host
name consists of the full domain extended host name. For example:
22.214.171.124 hpdxsg.xsg.hp.com hpdxsg testhost
A line cannot start with a blank (space or tab character). Items are
separated by any number or combination of space or tab characters
(blanks). A # character indicates the beginning of a comment.
Characters from the # to the end of the line are not interpreted by
routines that search the file. Trailing blanks are allowed at the end
of a line.
For the Internet, this file is normally created from the official host
database maintained at the Network Information Control Center (NIC),
although local changes may be required to bring it up to date with
respect to unofficial aliases and/or unknown hosts.
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
Network addresses are specified in the conventional Internet dot
notation using the inet_addr() routine from the Internet address
manipulation library (see inet(3N)). Host names can contain any
printable character other than a white space, newline, or comment
hosts was developed by the University of California, Berkeley.
gethostent(3N), inet(3N), nsswitch.conf(4).
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000