holidays(4) File Formats holidays(4)
holidays - prime/nonprime table for the accounting system
The /etc/acct/holidays file describes which hours are considered prime
time and which days are holidays. Holidays and weekends are consid-
ered non-prime time hours. /etc/acct/holidays is used by the account-
All lines beginning with an "*" are comments.
The /etc/acct/holidays file consists of two sections. The first non-
comment line defines the current year and the start time of prime and
non-prime time hours, in the form:
current_year prime_start non_prime_start
The remaining non-comment lines define the holidays in the form:
Of these two fields, only the month/day is actually used by the
accounting system programs.
The /etc/acct/holidays file must be updated each year.
Example 1: Example of the /etc/acct/holidays file.
The following is an example of the /etc/acct/holidays file:
* Prime/Nonprime Table for the accounting system
* Curr Prime Non-Prime
* Year Start Start
1991 0830 1800
* only the first column (month/day) is significant.
* month/day Company Holiday
1/1 New Years Day
5/30 Memorial Day
7/4 Indep. Day
9/5 Labor Day
11/24 Thanksgiving Day
11/25 day after Thanksgiving
12/26 day after Christmas
SunOS 5.10 28 Mar 1991 holidays(4)