GTP(4) BSD Kernel Interfaces Manual GTP(4)
gtp -- Gemtek PCI FM radio device
gtp* at pci? flags 0x00
radio* at gtp?
The gtp driver provides support for the Gemtek PCI and Guillemot MaxiRa-
dio FM2000 FM radio tuners.
The Gemtek PCI cards are stereo FM tuners that can tune in the range 87.5
- 108.0 MHz, report signal status and stereo/mono on the current fre-
quency, force audio output to mono, perform hardware signal search, and
have an internal AFC.
The card is based on the TEA5757 chip; see radio(4) for details.
The flags control the driver behavior. For example, with flags 0x01 the
driver will assume that a TEA5759 chip is used.
intro(4), pci(4), radio(4), radio(9)
The gtp device driver appeared in OpenBSD 3.2.
The gtp driver and the man page was written by Vladimir Popov
It is impossible to determine which frequency the card is tuned to.
Thus, the driver will report an internally stored value even if it is not
correct (changed by some program that uses direct port access).
BSD March 28, 2017 BSD