gettydefs - speed and terminal settings used by getty
The /etc/gettydefs file contains information used by getty to set up
the speed and terminal settings for a line (see getty(1M)). It
supplies information on what the login prompt should look like. It
also supplies the speed to try next if the user indicates the current
speed is not correct by typing a Break character.
Each entry in /etc/gettydefs has the following format:
label# initial-flags # final-flags # login-prompt #next-label
Each entry is followed by a blank line. The various fields can
contain quoted characters of the form \b, \n, \c, etc., as well as
\nnn, where nnn is the octal value of the desired character. The
various fields are:
label This is the string against which getty tries to match
its second argument. It is often the speed, such as
1200, at which the terminal is supposed to run, but it
need not be (see below).
initial-flags These flags are the initial ioctl() settings to which
the terminal is to be set if a terminal type is not
specified to getty (see ioctl(2)). The flags that
getty understands are the same as the ones listed in
/usr/include/sys/termio.h (see termio(7)). Normally
only the speed flag is required in the initial-flags.
getty automatically sets the terminal to raw input mode
and takes care of most of the other flags. The
initial-flag settings remain in effect until getty
final-flags These flags take the same values as the initial-flags
and are set just before getty executes login. The
speed flag is again required. The composite flag SANE
takes care of most of the other flags that need to be
set so that the processor and terminal are
communicating in a rational fashion. The other two
commonly specified final-flags are TAB3, so that tabs
are sent to the terminal as spaces, and HUPCL, so that
the line is hung up on the final close.
login-prompt This entire field is printed as the login-prompt.
Unlike the above fields where white space is ignored (a
space, tab or new-line), they are included in the
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
next-label If this entry does not specify the desired speed,
indicated by the user typing a Break character, getty
searches for the entry with next-label as its label
field and set up the terminal for those settings.
Usually, a series of speeds are linked together in this
fashion, into a closed set. For example, 2400 linked
to 1200, which in turn is linked to 300, which finally
is linked to 2400.
If getty is called without a second argument, the first entry of
/etc/gettydefs is used, thus making the first entry of /etc/gettydefs
the default entry. It is also used if getty cannot find the specified
label. If /etc/gettydefs itself is missing, there is one entry built
into the command which brings up a terminal at 300 baud.
It is strongly recommended that after making or modifying
/etc/gettydefs, it be run through getty with the check option to
ensure that there are no errors.
The following two lines show an example of 300/1200 baud toggle, which
is useful for dial-up ports:
1200# B1200 HUPCL # B1200 SANE IXANY IXANY TAB3 #login: #300
300# B300 HUPCL # B300 SANE IXANY IXANY TAB3 #login: #1200
The following line shows a typical 9600 baud entry for a hard-wired
9600# B9600 # B9600 SANE IXANY IXANY ECHOE TAB3 #login: #9600
getty(1M), login(1), ioctl(2), termio(7).
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000