ftpservers(4) File Formats ftpservers(4)
ftpservers - FTP Server virtual hosting configuration file
The ftpservers file is used to configure complete virtual hosting. In
contrast to limited virtual hosting, complete virtual hosting allows
separate configuration files to be specified for each virtual host.
The set of configuration files for each virtual host are placed in
their own directory. The ftpservers file associates the address of each
virtual host with the directory its configuration files are stored in.
The virtual host configuration files must be named:
ftpaccess Virtual host's access file
ftpusers Restricts the accounts that can use the virtual
ftpgroups Virtual hosts enhanced group access file
ftphosts Allow or deny usernames access to the virtual
ftpconversions Customize conversions available from the vir-
You do not need to put every file in each virtual host directory. If
you want a virtual host to use the master copy of a file, then do not
include it in the virtual host directory. If the file is not included,
the master copy from the /etc/ftpd directory will be used.
The file names must match exactly. If you misspell any of them or name
them differently, the server will not find them, and the server will
use the master copy instead.
The ftpaddhost utility is an administrative tool to configure virtual
hosts. See ftpaddhost(1M).
There are two fields to each entry in the ftpservers file:
When an FTP client connects to the FTP Server, in.ftpd(1M) tries to
match the IP address to which the FTP client connected with one found
in the ftpservers file.
The address can be an IPv4 or IPv6 address, or a hostname.
If a match is found, The FTP server uses any configuration files found
in the associated directory.
If a match is not found, or an invalid directory path is encountered,
the default paths to the configuration files are used. The use of
INTERNAL in the example above fails the check for a specific directory,
and the master configuration files will be used.
Either the actual IP address or a specific hostname can be used to
specify the virtual host. It is better to specify the actual IP of the
virtual host, as it reduces the need for a domain lookup and eliminates
DNS security related naming issues, for example:
Lines that begin with a # sign are treated as comment lines and are
See attributes(5) for descriptions of the following attributes:
tab() allbox; cw(2.750000i)| cw(2.750000i) lw(2.750000i)|
lw(2.750000i). ATTRIBUTE TYPEATTRIBUTE VALUE AvailabilitySUNWftpr
ftpaddhost(1M), in.ftpd(1M), ftpaccess(4), ftpconversions(4), ftp-
groups(4), ftphosts(4), ftpusers(4), attributes(5)
SunOS 5.10 1 May 2003 ftpservers(4)