ESS(4) Kernel Interfaces Manual ESS(4)
ess -- ESS Technology AudioDrive family audio device driver
ess* at isapnp?
ess* at pnpbios? index ?
ess* at ofisa?
audio* at audiobus?
opl* at ess?
The ess driver provides support for the ESS 1788, 1888, 1887, and 888
AudioDrive audio devices.
The AudioDrive 1788 is a half-duplex device, while the 1888, 1887, and
888 are full-duplex. All are capable of 8- and 16-bit audio sample
recording and playback at rates up to 44.1kHz.
The AudioDrive takes 16 I/O ports. The I/O port range, IRQ, and DRQ
channels are set by the driver to the values specified in the
configuration file (or for isapnp, pnpbios, or ofisa, the values assigned
from the firmware). The I/O port base must be one of 0x220, 0x230,
0x240, 0x250. The IRQ must be one of 5, 7, 9, 10 (or 15 on the 1887
only). The first DRQ channel must be selected from 0, 1, 3. The second
DRQ channel (used for playback by the full-duplex 1888/1887, ignored by
the 1788) can additionally be set to 5. If both DRQ channels are used
they must be different.
The joystick interface (if enabled) is handled by the joy(4) driver.
audio(4), isapnp(4), joy(4), ofisa(4), opl(4), pnpbios(4)
The ess device driver appeared in NetBSD 1.4.
The AudioDrive devices have a SoundBlaster compatibility mode, and may be
detected by the SoundBlaster driver (see sb(4)) rather than the
AudioDrive driver. The workaround is to remove the SoundBlaster driver
from the kernel configuration.
NetBSD 6.1.5 June 22, 2005 NetBSD 6.1.5