DPT(4) BSD Kernel Interfaces Manual DPT(4)
dpt -- DPT EATA SCSI RAID controller
dpt* at eisa?
dpt* at pci?
The dpt driver provides support for the following SCSI adapters:
DPT SmartCache III
DPT SmartCache IV
DPT SmartRAID III
DPT SmartRAID IV
None of these messages should be encountered under normal circumstances.
It should be noted that the list below is not complete.
dpt0: readcfg failed - see dpt(4) The EATA configuration data did not
appear upon request. This may be caused by older firmware. Generally
the solution is to power-cycle the affected machine.
dpt0: spurious intr A spurious interrupt was received from the HBA.
dpt0: bogus status (returned CCB id NNNN) A corrupt or incomplete status
packet was received from the HBA.
cd(4), ch(4), eisa(4), intro(4), pci(4), scsi(4), sd(4), st(4)
This manpage is inadequate.
The dpt driver first appeared in OpenBSD 2.5.
The dpt driver was written by Andy Doran <firstname.lastname@example.org>, based upon the
uha and bha drivers, which are the work of others.
EATA adapters other than listed may function correctly with the dpt
driver, however a definitive list is not available.
Older firmware may prove problematic. It is recommended that the latest
available firmware be used. Contact DPT for a firmware update.
Older boards that do not support scatter-gather I/O or DMA are not sup-
An ISA front-end is needed.
ECC formatted disk and arrays (i.e., with a sector size of 528 bytes) do
not work correctly with the PM2041 and certain firmware revisions of the
BSD July 16, 2013 BSD