dat.conf(4) File Formats dat.conf(4)
dat.conf - DAT static registry
The DAT static registry, /etc/dat/dat.conf is a system-wide data
resource maintained by the system administrative command datadm(1M).
/etc/dat/dat.conf contains a list of interface adapters supported by
uDAPL service providers. An interface adapter on Infiniband (IB) corre-
sponds to an IPoIB device instance, for example, ibd0. An IPoIB device
name represents an IP interface plumbed by ifconfig(1M) on an IB parti-
tion/Host Channel Adapter port combination.
Each entry in the DAT static registry is a single line that contains
eight fields. Fields are separated by a <<SPACE>>. Lines that begin with
a pound sign (#) are considered comments. All characters that follow
the # are ignored. Enclose Solaris specific strings (Solaris_spe-
cific_string) and service provider's instance data (service
_provider_instance_data) in quotes.
The following shows the order of the fields in a dat.conf entry:
"interface_adapter_name" "API_version" "threadsafe | nonthreadsafe" \
"default | nondefault" "service_provider_library_pathname" \
"service_provider_version" "service _provider_instance_data"\
The fields are defined as follows:
Specifies the Interface Adapter (IA) name. In IB, this is the IPoIB
device instance name, for example, ibd0. This represents an IP
interface plumbed on an IB partition/port combination of the HCA.
Specifies the API version of the service provide library: For exam-
ple, "u"major.minor is u1.2.
threadsafe | nonthreadsafe
Specifies a threadsafe or non-threadsafe library.
default | nondefault
Specifies a default or non-default version of library. A service
provider can offer several versions of the library. If so, one ver-
sion is designated as default with the rest as nondefault.
Specifies the pathname of the library image.
Specifies the version of the service provider. By convention, spec-
ify the company stock symbol as the service provider, followed by
major and minor version numbers, for example, SUNW1.0.
Specifies the service provider instance data.
Specifies a platform specific string, for example, the device name
in the service_provider.conf file.
Example 1: Sample dat.conf File
The following dat.conf file shows a uDAPL 1.2 service provider for
tavor, udapl_tavor.so.1 supporting two interfaces, ibd0 and ibd1:
# dat.conf for uDAPL 1.2
ibd0 u1.2 nonthreadsafe default udapl_tavor.so.1 SUNW.1.0 ""
ibd1 u1.2 nonthreadsafe default udapl_tavor.so.1 SUNW.1.0 ""
See attributes(5) for descriptions of the following attributes:
tab() allbox; cw(2.750000i)| cw(2.750000i) lw(2.750000i)|
lw(2.750000i). ATTRIBUTE TYPEATTRIBUTE VALUE AvailabilitySUNWudaplr
datadm(1M), ifconfig(1M), libdat(3LIB), service_provider.conf(4),
An empty dat.conf is created during the package SUNWudaplr installation
if no file is present beforehand. Entries in the file are added or
removed by running datadm(1M).
The content of the platform specific string does not constitute an API.
It is generated by datadm(1M) and might have a different content or
interpretation in a future release.
SunOS 5.10 18 Jun 2004 dat.conf(4)