crypto_certs(4) File Formats crypto_certs(4)
crypto_certs - directory for certificate files for Solaris Crypto-
The /etc/crypto/certs directory contains ASN.1 BER or PEM encoded cer-
tificate files for use by the Solaris Cryptographic Framework.
A default installation contains only two certificates. The CA certifi-
cate is the trust anchor for all other certificates. The SUNWosnet cer-
tificate contains the certificate use to sign the Solaris user and ker-
nel cryptographic plug-ins.
Additional certificates my be installed by third-party cryptographic
providers. They should either be copied to /etc/crypto/certs or
included in the package that delivers the provider.
Only certificates that are issued by the CA certificate are accepted by
the Solaris Cryptographic Framework. This restriction is in place due
to US Export Law on the export of open cryptographic interfaces at the
time of shipping this revision of the product.
See attributes(5) for descriptions of the following attributes:
tab() allbox; cw(2.750000i)| cw(2.750000i) lw(2.750000i)|
lw(2.750000i). ATTRIBUTE TYPEATTRIBUTE VALUE AvailabilitySUNWcsr
elfsign(1), libpkcs11(3LIB), attributes(5)
SunOS 5.10 26 Feb 2004 crypto_certs(4)