CLTP(4) Kernel Interfaces Manual CLTP(4)
cltp -- ISO Connectionless Transport Protocol
socket(AF_ISO, SOCK_DGRAM, 0);
CLTP is a simple, unreliable datagram protocol which is accessed via the
SOCK_DGRAM abstraction for the ISO protocol family. CLTP sockets are
connectionless, and are normally used with the sendto(2) and recvfrom(2)
calls, though the connect(2) call may also be used to fix the destination
for future packets (in which case the recv(2) or read(2) and send(2) or
write(2) system calls may be used).
CLTP address formats are identical to those used by TP. In particular
CLTP provides a service selector in addition to the normal ISO NSAP.
Note that the CLTP selector space is separate from the TP selector space
(i.e. a CLTP selector may not be ``connected'' to a TP selector).
Options at the CLNP network level may be used with CLTP; see clnp(4).
A socket operation may fail with one of the following errors returned:
[EISCONN] when trying to establish a connection on a socket which
already has one, or when trying to send a datagram with
the destination address specified and the socket is
[ENOTCONN] when trying to send a datagram, but no destination
address is specified, and the socket hasn't been
[ENOBUFS] when the system runs out of memory for an internal data
[EADDRINUSE] when an attempt is made to create a socket with a
selector which has already been allocated;
[EADDRNOTAVAIL] when an attempt is made to create a socket with a
network address for which no network interface exists.
getsockopt(2), recv(2), send(2), socket(2), clnp(4), intro(4), iso(4)
NetBSD 6.1.5 June 9, 1993 NetBSD 6.1.5