CISS(4) BSD Kernel Interfaces Manual CISS(4)
ciss -- Compaq Smart ARRAY 5/6 SAS/SATA/SCSI RAID controller
ciss* at pci?
The ciss driver provides support for the Compaq Smart ARRAY 5th and 6th
family of RAID controllers, including:
o Compaq 532, 5300, 5312, 5i
o Compaq 641, 642, 6400, 6400EM, 6422
o Hewlett-Packard 6i, E200, E200i, E500, H240, H240ar,
H240tr, H241, H244br, P212, P220i, P222, P224br, P230i,
P240tr, P246br, P400, P400i, P410, P410i, P411, P420,
P420i, P421, P430, P430i, P431, P440, P440ar, P441, P530,
P531, P542t, P600, P700m, P711m, P712m, P721m, P731m,
P741m, P800, P812, P822, P830, P830i, P840, P841, V100
These controllers support RAID 0, RAID 1, RAID 5, JBOD, and superposi-
tions of those configurations.
Although the controllers are actual RAID controllers, the driver makes
them look just like SCSI controllers. All RAID configuration is done
through the controllers' BIOSes.
Monitoring status for the volume and drives in it is done through the
bioctl(8) utility; the current status is provided by the sysctl(8) vari-
bio(4), intro(4), pci(4), scsi(4), sd(4), bioctl(8), sensorsd(8),
The ciss driver first appeared in OpenBSD 3.8.
The ciss driver was written by Michael Shalayeff <firstname.lastname@example.org>.
For purposes of status monitoring, the current code only supports one
logical volume per controller.
BSD September 13, 2014 BSD