cdnode - format of a CDFS cdnode
This entry describes the cdnode structure and related concepts for the
CDFS file system. Refer to other inode(4) manual pages for
information regarding the inode structure for other file systems.
The CDFS file system does not have the concept of a separate entity
called an inode. The information normally found in an HFS inode is
kept in a cdnode data structure. However, the cdnode data structure
does not reside on the physical media, but instead is kept in kernel
memory space only. The cdnode information is used to uniquely
identify a file.
The information kept in the cdnode structure is obtained from two
other data structures in the CDFS file system:
1. Directory record for the file or directory, and
2. Extended attribute record (XAR) for the file or directory,
if one exists.
Because few files usually have XARs associated with them, the cdnode
information most often consists only of attributes given by the
directory record for the file.
Since cdnodes are kept in kernel memory, they cannot be directly
accessed by the user. The stat() system call attempts to map whatever
information is included in the cdnode for a given file into the
standard stat structure (see stat(2)). However, since a cdnode
includes information that does not have corresponding fields in the
stat structure, that information cannot be mapped and therefore cannot
be accessed. No method is provided to access an entire cdnode
stat(2), cdrom(4), cdfsdir(4).
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000