CDCE(4) BSD Kernel Interfaces Manual CDCE(4)
cdce -- USB Communication Device Class Ethernet device
cdce* at uhub?
The cdce driver provides support for USB Host-to-Host (aka USB-to-USB)
bridges based on the USB Communication Device Class (CDC) and Ethernet
subclass, including the following:
o Acer Labs USB 2.0 Data Link
o Dell Wireless 5530
o Dell Wireless 5540
o FRITZ!Box Fon ata 1020
o G.Mate YP3X00
o Motorola USBNET
o NetChip EthernetGadget
o Prolific PL-2501
o Sharp Zaurus
o Sony Ericsson K610i
o Sony Ericsson F3705g
o Yota LU156
o Zyxel P-971M
The USB bridge appears as a regular network interface on both sides,
transporting Ethernet frames. USB 1.x bridges support speeds of up to
12Mbps, and USB 2.0 speeds of up to 480Mbps. Packets are received and
transmitted over separate USB bulk transfer endpoints.
The cdce driver does not support different media types or options. For
more information on configuring this device, see ifconfig(8).
cdce0: extra ethernet descriptor There is more than one Ethernet
cdce0: no data interface The data interface announced by the union
descriptor cannot be found.
cdce0: no descriptor for interrupt endpoint N
cdce0: interface alternate setting N failed
cdce0: no descriptor for bulk endpoint N
cdce0: could not find data bulk in/out For a manually added USB ven-
dor/product, these errors indicate that the bridge is not compatible with
cdce0: watchdog timeout A packet was queued for transmission and a
transmit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
cdce0: no memory for rx list -- packet dropped! Memory allocation
through MGETHDR or MCLGET failed, the system is running low on mbufs.
cdce0: abort/close rx/tx/interrupt pipe failed
cdce0: rx/tx list init failed
cdce0: open rx/tx/interrupt pipe failed
cdce0: usb error on rx/tx
arp(4), cdcef(4), intro(4), netintro(4), usb(4), hostname.if(5),
Universal Serial Bus Class Definitions for Communication Devices,
Data sheet Prolific PL-2501 Host-to-Host Bridge/Network Controller.
The cdce device driver first appeared in OpenBSD 3.6.
The cdce driver was written by Craig Boston <firstname.lastname@example.org> based
on the aue(4) driver written by Bill Paul <email@example.com> and
ported to OpenBSD by Daniel Hartmeier <firstname.lastname@example.org>.
Many USB devices notoriously fail to report their class and interfaces
correctly. Undetected products might work flawlessly when their vendor
and product IDs are added to the driver manually.
BSD April 26, 2017 BSD