CDCE(4) Kernel Interfaces Manual CDCE(4)
cdce -- USB Communication Device Class Ethernet driver
cdce* at uhub? port ?
The cdce driver provides support for USB Host-to-Host (aka USB-to-USB)
bridges based on the USB Communication Device Class (CDC) and Ethernet
subclass, including the following:
o Acer Labs USB 2.0 Data Link
o G.Mate YP3X00
o Motorola USBNET
o NetChip EthernetGadget
o Prolific PL-2501
o Sharp Zaurus
The USB bridge appears as a regular network interface on both sides,
transporting Ethernet frames.
For more information on configuring this device, see ifconfig(8).
USB 1.x bridges support speeds of up to 12Mbps, and USB 2.0 speeds of up
Packets are received and transmitted over separate USB bulk transfer
The cdce driver does not support different media types or options.
cdce%d: no union descriptor The driver couldn't fetch an interface
descriptor from the USB device. For a manually added USB vendor/product,
the CDCE_NO_UNION flag can be tried to work around the missing
cdce%d: no data interface
cdce%d: could not read endpoint descriptor
cdce%d: unexpected endpoint
cdce%d: could not find data bulk in/out For a manually added USB
vendor/product, these errors indicate that the bridge is not compatible
with the driver.
cdce%d: watchdog timeout A packet was queued for transmission and a
transmit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
cdce%d: no memory for rx list -- packet dropped! Memory allocation
through MGETHDR or MCLGET failed, the system is running low on mbufs.
cdce%d: abort/close rx/tx pipe failed
cdce%d: rx/tx list init failed
cdce%d: open rx/tx pipe failed
cdce%d: usb error on rx/tx
arp(4), intro(4), netintro(4), usb(4), ifconfig(8)
Universal Serial Bus Class Definitions for Communication Devices,
Data sheet Prolific PL-2501 Host-to-Host Bridge/Network Controller,
The cdce device driver first appeared in OpenBSD 3.6 and NetBSD 3.0.
The cdce driver was written by Craig Boston <craigATtobuj.org> based
on the aue(4) driver written by Bill Paul <wpaulATwindriver.com> and
ported to OpenBSD by Daniel Hartmeier <dhartmeiATopenbsd.org>.
Many USB devices notoriously fail to report their class and interfaces
correctly. Undetected products might work flawlessly when their vendor
and product IDs are added to the driver manually.
NetBSD 6.1.5 June 7, 2011 NetBSD 6.1.5