CAC(4) BSD Kernel Interfaces Manual CAC(4)
cac -- Compaq Smart ARRAY 2/3/4 SCSI RAID controller
cac* at pci?
cac* at eisa?
The cac driver provides support for the following RAID controllers:
o Compaq Integrated Array
o Compaq IAES
o Compaq IDA
o Compaq IDA-2
o Compaq RAID LC2
o Compaq Smart ARRAY 221
o Compaq Smart ARRAY 3100ES
o Compaq Smart ARRAY 3200
o Compaq Smart ARRAY 4200
o Compaq Smart ARRAY 4250ES
o Compaq Smart ARRAY 431
o Compaq SMART
o Compaq SMART-2/E
o Compaq SMART-2/P
o Compaq SMART-2DH
o Compaq SMART-2SL
All the RAID set volume management is done via the card BIOS.
Although the controllers are actual RAID controllers the driver makes
them look just like SCSI controllers. All RAID configuration is done
through the controllers' BIOSes.
Monitoring status for the volume and drives in it is done through the
bioctl(8) utility; the current status is provided by the sysctl(8) vari-
bio(4), eisa(4), intro(4), pci(4), scsi(4), sd(4), bioctl(8),
The cac driver first appeared in OpenBSD 2.9.
The cac driver was written by Michael Shalayeff <email@example.com>,
inspired by the NetBSD driver by Andrew Doran <firstname.lastname@example.org>.
BSD March 28, 2017 BSD