BWI(4) BSD Kernel Interfaces Manual BWI(4)
bwi -- Broadcom AirForce IEEE 802.11b/g wireless network device
bwi* at cardbus?
bwi* at pci?
The bwi driver provides support for Broadcom AirForce based PCI/Cardbus
These are the modes the bwi driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The bwi driver can be configured to use Wired Equivalent Privacy (WEP) or
Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless communica-
tion, due to serious weaknesses in it. The bwi driver relies on the
software 802.11 stack for both encryption and decryption of data frames.
The transmit speed is user-selectable or can be adapted automatically by
the driver depending on the received signal strength and on the number of
hardware transmission retries.
The bwi driver can be configured at runtime with ifconfig(8) or on boot
The driver needs a firmware file which is loaded when an interface is
A prepackaged version of the firmware can be installed using
The following cards are among those supported by the bwi driver:
Card Chip Bus Standard
Apple Airport Extreme BCM4306 PCI b/g
Apple Airport Extreme BCM4318 PCI b/g
ASUS WL-138g BCM4318 PCI b/g
Buffalo WLI-CB-G54 BCM4306 CardBus b/g
Compaq R4035 onboard BCM4306 PCI b/g
HP nx6125 BCM4319 PCI b/g
Linksys WPC54G Ver 3 BCM4318 CardBus b/g
Linksys WPC54GS Ver 2 BCM4318 CardBus b/g
TRENDnet TEW-401PCplus BCM4306 CardBus b/g
US Robotics 5411 BCM4318 CardBus b/g
The following example scans for available networks:
# ifconfig bwi0 scan
The following hostname.if(5) example configures bwi0 to join network
``mynwid'', using WPA key ``mywpakey'', obtaining an IP address using
arp(4), cardbus(4), ifmedia(4), intro(4), netintro(4), pci(4),
The bwi driver first appeared in OpenBSD 4.3.
The bwi driver was written for DragonFly by Sepherosa Ziehau and ported
to OpenBSD by Jonathan Gray and Marcus Glocker.
Some chips are incorrectly calibrated due to the lack of documentation,
which can slow the amount of traffic to the point of being unusable.
Furthermore this driver only supports firmware version 3.
BSD April 30, 2017 BSD