AXE(4) BSD Kernel Interfaces Manual AXE(4)
axe -- ASIX Electronics AX88172/AX88178/AX88772 10/100/Gigabit USB Ether-
axe* at uhub?
rgephy* at mii?
rlphy* at mii?
eephy* at mii?
The axe driver provides support for USB Ethernet adapters based on the
ASIX Electronics AX88172, AX88178, and AX88772 USB 2.0 chipsets, includ-
ing the following:
Apple USB Ethernet Adapter A1277
Billionton Systems USB2AR
Corega FEther USB2-TX
Good Way GWUSB2E
Intellinet USB 2.0 to Ethernet (rev A)
Lenovo USB 2.0 Ethernet
Level One USB-0200
Level One USB-0301
Nintendo Wii USB Lan Ethernet Adapter RVL-015
OQO model 01+ Ethernet
SnapPort USB 2.0 LAN Adapter
ST Lab USB 2.0 Fast Ethernet
System TALKS SGC-X2UL
The AX88172, AX88178, and AX88772 are USB 2.0 devices designed to work
with either Ethernet or HomePNA transceivers. The AX88172 and AX88772
contain 10/100 Ethernet MACs with MII interfaces. The AX88178 contains a
10/100/Gigabit Ethernet MAC with a GMII/MII interface. All adapters will
operate with either USB 1.x or USB 2.0 controllers, however performance
with 1.x controllers will be limited since the USB 1.x standard specifies
a maximum transfer speed of 12Mbps. Users with USB 1.x controllers
should therefore not expect to actually achieve 100Mbps speeds with these
A 64-bit multicast hash table is supported, single perfect filter entry
for the station address, all-multicast mode, and promiscuous mode. Pack-
ets are received and transmitted over separate USB bulk transfer end-
The axe driver supports the following media types:
autoselect Enable autoselection of the media type and options (this is
the default). The user can manually override the autose-
lected mode by adding media options to the appropriate
10baseT Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
1000baseT Set 1000Mbps (Gigabit Ethernet) operation (AX88178 only).
The axe driver supports the following media options:
full-duplex Force full-duplex operation.
half-duplex Force half-duplex operation.
The interface will operate in half-duplex mode if no media option is
For more information on configuring this device, see ifconfig(8).
axe0: watchdog timeout A packet was queued for transmission and a trans-
mit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
axe0: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
arp(4), eephy(4), ifmedia(4), intro(4), netintro(4), rgephy(4), rlphy(4),
usb(4), hostname.if(5), ifconfig(8)
ASIX AX88172 data sheet, http://www.asix.com.tw.
The axe device driver first appeared in OpenBSD 3.6.
The axe driver was written by Bill Paul <firstname.lastname@example.org> and ported
to OpenBSD by Greg Taleck <email@example.com>.
BSD March 24, 2017 BSD