autofs(4) File Formats autofs(4)
autofs - file containing parameter values for automountd daemon and
The autofs file resides in directory /etc/default and supplies default
parameters for the automountd(1M) daemon and the automount(1M) command.
The autofs file format is ASCII; comment lines begin with the cross-
hatch (#) character. Parameters consist of a keyword followed by an
equal sign followed by the parameter value, of the form:
As shipped, the parameters in the autofs file are commented out. As
root, you must uncomment a keyword-value line to make the value for
that parameter take effect.
Administrators can make changes to the startup parameters for auto-
mountd by logging in as root and editing the autofs file. Changes made
to autofs values on an automount or automountd command line override
values in /etc/default/autofs.
Unlike /etc/init.d/autofs, the /etc/default/autofs file is preserved
across operating system upgrades.
The following parameters are currently supported in the autofs file:
Specifies a duration, in seconds, that a file system is to remain
mounted when not in use. The default value is 600 (10 minutes).
Equivalent to the -t option in automount.
AUTOMOUNT_VERBOSE=TRUE | FALSE
Verbose mode. Causes you to be notified of non-critical events,
suchs as autofs mounts and unmounts. The default value is FALSE.
Equivalent to the -v option in automount.
AUTOMOUNTD_VERBOSE=TRUE | FALSE
Verbose mode. Causes status messages to be logged to the console.
The default value is FALSE. Equivalent to the -v option in auto-
Turn on or off browsing for all autofs mount points. The default
value is FALSE. Equivalent to the -n option in automountd.
Expands each RPC call and displays it on standard output. The
default value, 0, turns off such tracing. Starting with 1, with
each higher value, the verbosity of trace output increases.
Environment variables. Each environment variable-value pairing must
be on its own line. You can specify multiple such pairings. There
are no environment variable settings supplied. For example: AUTO-
SunOS 5.10 12 Nov 2004 autofs(4)