AUICH(4) BSD Kernel Interfaces Manual AUICH(4)
auich -- Intel ICH integrated AC'97 audio device
auich* at pci? flags 0x0000
audio* at auich?
The auich driver provides support for the integrated AC'97 audio con-
troller present on the Intel ICH I/O controller hub and compatible
o AMD 768, 8111
o Intel 6300ESB/6321ESB
o Intel 82440MX
o Intel 82801 (ICH, ICH0, ICH2, ICH3, ICH4, ICH5, ICH6, ICH7)
o NVIDIA nForce, nForce2, nForce3, nForce4
o SiS 7012
The auich DMA engine supports full-duplex operation and has separate
channels for line input and microphone. Unfortunately, simultaneous
recording from both line and microphone inputs is not supported due to
the current ac97(4) design. Setting flags to 0x0001 will compensate for
machines that have reversed stereo.
ac97(4), audio(4), intro(4), pci(4)
The auich device driver appeared in OpenBSD 2.8.
Some hardware implementations only support 48kHz sampling rates.
BSD March 24, 2017 BSD