ATU(4) BSD Kernel Interfaces Manual ATU(4)
atu -- Atmel AT76C50x USB IEEE 802.11b wireless network device
atu* at uhub? port ?
The atu driver provides support for wireless network adapters based
around the Atmel AT76C503, AT76C503A, AT76C505, and AT76C505A USB
chipsets and four companion radio chipsets.
The atu driver encapsulates all IP and ARP traffic as 802.11 frames,
though it can receive either 802.11 or 802.3 frames.
These are the modes the atu driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
IBSS mode Also known as IEEE ad-hoc mode or peer-to-peer mode. This
is the standardized method of operating without an access
point. Stations associate with a service set. However,
actual connections between stations are peer-to-peer.
The atu driver can be configured to use hardware Wired Equivalent Privacy
(WEP). It is strongly recommended that WEP not be used as the sole mech-
anism to secure wireless communication, due to serious weaknesses in it.
The atu driver can be configured at runtime with ifconfig(8) or on boot
The following devices are known to be supported by the atu driver:
Acer Peripherals AWL300
Acer Peripherals AWL400
Askey Computer Voyager 1010
Askey Computer WLL013 (Intersil Radio)
Askey Computer WLL013 (RFMD Radio)
Atmel AT76C503 (Intersil Radio)
Atmel AT76C503 (RFMD Radio)
Atmel AT76C505 (RFMD Radio)
Atmel AT76C505 (RFMD 2958 Radio)
Atmel AT76C505A (RFMD 2958 Radio)
Atmel AT76C505AS (RFMD 2958 Radio)
Compaq iPAQ h54xx/h55xx Internal WLAN
Corega WLAN USB Stick 11
Dick Smith Electronics CHUSB 611G
Dick Smith Electronics WL200U
Dick Smith Electronics WL240U
Dick Smith Electronics XH1153
D-Link DWL-120 rev E
Intel AP310 AnyPoint II
I/O DATA USB WN-B11
Linksys WUSB11 802.11b
Linksys WUSB11 802.11b v2.8
Netgear MA101 rev B
OQO model 01 WiFi
Ovislink AirLive WL-1120USB
OvisLink AirLive WL-1130USB
Planex Communications GW-US11S
SMC EZ Connect 11Mbps (SMC2662w)
SMC EZ Connect 11Mbps v2 (SMC2662wV2)
The adapter needs some firmware files, which are loaded on demand by the
driver when the device is attached:
The following example scans for available networks:
# ifconfig atu0 scan
The following hostname.if(5) example configures atu0 to join network
``mynwid'', using WEP key ``mywepkey'', obtaining an IP address using
arp(4), ifmedia(4), intro(4), netintro(4), usb(4), hostname.if(5),
The atu driver was written by Daan Vreeken and ported to OpenBSD by Theo
de Raadt and David Gwynne.
The atu driver does not support a lot of the functionality available in
the hardware. More work is required to properly support the IBSS, power
management, and selectable transmission rate features.
BSD October 19, 2013 BSD