ATARAID(4) Kernel Interfaces Manual ATARAID(4)
ataraid -- software BIOS RAID
ld* at ataraid? vendtype ? unit ?
The ataraid driver provides support for BIOS-based software RAID
controllers. These are devices which have some simple support for
several basic RAID levels (often RAID 0 and RAID 1), but which require
software support to actually perform the RAID function. The BIOS support
is largely just to create and recognize the array so that it may be a
The driver currently supports RAID formats from:
o Adaptec HostRAID (found in Intel 6300ESB)
o Intel MatrixRAID
o JMicron RAID
o nVidia MediaShield
o Promise FastTrak
o Via V-RAID (found in many VIA-based motherboards)
Status of the logical disk as well as the disks associated with it, can
be viewed through the bioctl(8) utility.
The ataraid driver first appeared in NetBSD 2.0.
The ataraid driver was originally adapted from FreeBSD by Jason Thorpe
Not all features of the software RAID are currently recognized or
supported. For example, the Adaptec support doesn't recognize when a
RAID 1 should be in a ``building'' state, and it does not do the right
At least part of the reason for this is that the publically-available
information on these formats is quite limited.
NetBSD 6.1.5 September 16, 2008 NetBSD 6.1.5