ARCMSR(4) BSD Kernel Interfaces Manual ARCMSR(4)
arcmsr -- Areca SATA II RAID Controller driver
The arcmsr driver provides support for the Areca ARC-11xx and ARC-12xx
series of SATA II RAID controllers. These controllers feature RAID-0, 1,
3, 5, 6, and 10 and JBOD acceleration for up to 16 SATA drives. Raid
level and stripe level migration, online capacity expansion, hot inser-
tion/removal, automatic failover and rebuild, and SMART are also sup-
ported. Access to the arrays is provided via the SCSI CAM /dev/da?
device nodes. A management interface is also present via the
/dev/arcmsr? device node. Management tools for i386 and amd64 are avail-
able from Areca.
The arcmsr driver supports the following cards:
/dev/da? Array block device
/dev/arcmsr? Management interface
/boot/kernel/arcmsr.ko Loadable module
The arcmsr driver first appeared in FreeBSD 5.4.
The driver was written by Erich Chen <erichATareca.tw>.
The driver has been tested on i386 and amd64. It likely requires addi-
tional work to function on big-endian architectures.
BSD March 31, 2005 BSD