APS(4) BSD Kernel Interfaces Manual APS(4)
aps -- ThinkPad Active Protection System accelerometer
aps0 at isa? port 0x1600
The aps driver provides support for several sensors found in some
The sensors currently exposed via the sysctl(8) interface are:
Sensor Units Typical Use
X_ACCEL Unknown X Acceleration
Y_ACCEL Unknown Y Acceleration
X_VAR Unknown Weighted X Acceleration?
Y_VAR Unknown Weighted Y Acceleration?
Temp1 uK Unknown
Temp2 uK Unknown
Keyboard Active boolean Keyboard activity
Mouse Active boolean Mouse activity
Lid Open boolean Lid state
isa(4), sensorsd(8), sysctl(8)
The aps driver first appeared in OpenBSD 3.8.
The aps driver was written by Jonathan Gray <firstname.lastname@example.org>.
The aps driver does not yet maintain state and subsequently does not take
evasive action when it thinks the hard drive is in danger.
The Y axis on X40 and possibly other models seems to be inverted. It is
unknown how to distinguish between different versions of the accelerome-
ter to compensate for this in the driver at this time.
As IBM provides no documentation, it is not known what all the available
sensors are used for.
BSD July 16, 2013 BSD