AMR(4) BSD Kernel Interfaces Manual AMR(4)
amr -- MegaRAID SCSI/ATA/SATA RAID driver
The amr driver provides support for LSI Logic MegaRAID SCSI RAID con-
trollers and legacy American Megatrends MegaRAID SCSI RAID controllers,
including models relabeled and sold by Dell and Hewlett-Packard.
Controllers supported by the amr driver include:
o MegaRAID SCSI 320-1E
o MegaRAID SCSI 320-2E
o MegaRAID SCSI 320-4E
o MegaRAID SCSI 320-0X
o MegaRAID SCSI 320-2X
o MegaRAID SCSI 320-4X
o MegaRAID SATA 300-4X
o MegaRAID SATA 300-8X
o MegaRAID SATA 150-4
o MegaRAID SATA 150-6
o MegaRAID i4 133 RAID
o MegaRAID SCSI 320-0
o MegaRAID SCSI 320-1
o MegaRAID SCSI 320-2
o MegaRAID SCSI 320-4
o MegaRAID Series 418
o MegaRAID Enterprise 1200 (Series 428)
o MegaRAID Enterprise 1300 (Series 434)
o MegaRAID Enterprise 1400 (Series 438)
o MegaRAID Enterprise 1500 (Series 467)
o MegaRAID Enterprise 1600 (Series 471)
o MegaRAID Elite 1500 (Series 467)
o MegaRAID Elite 1600 (Series 493)
o MegaRAID Elite 1650 (Series 4xx)
o MegaRAID Express 100 (Series 466WS)
o MegaRAID Express 200 (Series 466)
o MegaRAID Express 300 (Series 490)
o MegaRAID Express 500 (Series 475)
o Dell PERC
o Dell PERC 2/SC
o Dell PERC 2/DC
o Dell PERC 3/DCL
o Dell PERC 3/QC
o Dell PERC 4/Di
o Dell PERC 4e/Di
o Dell PERC 4e/Si
o Dell PERC 4ei
o HP NetRAID-1/Si
o HP NetRAID-3/Si (D4943A)
o HP Embedded NetRAID
o Intel RAID Controller SRCS16
o Intel RAID Controller SRCU42X
Driver initialisation/shutdown phase
amr%d: memory window not available
amr%d: I/O window not available
The PCI BIOS did not allocate resources necessary for the correct opera-
tion of the controller. The driver cannot attach to this controller.
amr%d: busmaster bit not set, enabling
The PCI BIOS did not enable busmaster DMA, which is required for the cor-
rect operation of the controller. The driver has enabled this bit and
initialisation will proceed.
amr%d: can't allocate register window
amr%d: can't allocate interrupt
amr%d: can't set up interrupt
amr%d: can't allocate parent DMA tag
amr%d: can't allocate buffer DMA tag
amr%d: can't allocate scatter/gather DMA tag
amr%d: can't allocate s/g table
amr%d: can't allocate mailbox tag
amr%d: can't allocate mailbox memory
A resource allocation error occurred while initialising the driver; ini-
tialisation has failed and the driver will not attach to this controller.
amr%d: can't obtain configuration data from controller
amr%d: can't obtain product data from controller
The driver was unable to obtain vital configuration data from the con-
troller. Initialisation has failed and the driver will not attach to
amr%d: can't establish configuration hook
amr%d: can't scan controller for drives
The scan for logical drives managed by the controller failed. No drives
will be attached.
amr%d: device_add_child failed
amr%d: bus_generic_attach returned %d
Creation of the logical drive instances failed; attachment of one or more
logical drives may have been aborted.
amr%d: flushing cache...
The controller cache is being flushed prior to shutdown or detach.
amr%d: I/O beyond end of unit (%u,%d >> %u)
A partitioning error or disk corruption has caused an I/O request beyond
the end of the logical drive. This may also occur if FlexRAID Virtual
Sizing is enabled and an I/O operation is attempted on a portion of the
virtual drive beyond the actual capacity available.
amr%d: polled command timeout
An initialisation command timed out. The initialisation process may fail
as a result.
amr%d: bad slot %d completed
The controller reported completion of a command that the driver did not
issue. This may result in data corruption, and suggests a hardware or
firmware problem with the system or controller.
amr%d: I/O error - %x
An I/O error has occurred.
cd(4), da(4), sa(4), scsi(4)
The amr driver was written by Mike Smith <msmithATFreeBSD.org>.
This manual page was written by Mike Smith <msmithATFreeBSD.org> and
Jeroen Ruigrok van der Werven <asmodaiATFreeBSD.org>.
BSD March 4, 2005 BSD